Скачать бесплатно — Редактор DBF

Многофункциональное приложение для просмотра электронных баз данных DBF. В программу встроены возможности импорта и экспорта с другими форматами, инструменты для поиска и редактирования данных в таблице, а также поддерживает возможность вывода на печать.

DBF Viewer Plus для работы с БД для windows

DBF Viewer Plus является портативным приложением и не требует инсталляции на диск. Интерфейс программы очень прост и удобен. Расположение всех необходимых инструментов продуманно организовано. Открытие файлов DBF осуществляется с помощью файлового проводника, так как поддержка функции перетаскивания (drag-and-drop) не реализована.

Основные возможности DBF Viewer Plus:

  • Открытие и просмотр файлов DBF
  • Использование различных фильтров для отображения данных
  • Вывод на печать с предварительным просмотром
  • Добавление, редактирование, удаление и обновление записей
  • Поиск значений (точных или по маске)
  • Сжатие таблиц
  • Показать / скрыть столбцы
  • Экспорт в форматы: TXT, PDF, XLS, RTF, WKS, XML, HTML, DBF и CSV
  • Создание новых таблиц баз данных DBF

Develop Базы данных

Похожие программы на DBF Viewer Plus

из раздела «Базы данных» Конвертер файлов / Документы / DBF

+ Выберите файл для преобразования в .dbf или перетащите файл сюда

Вы можете перевести документы в формат DBF с помощью бесплатного онлайн конвертера.

Как сконвертировать в dbf Шаг 1

Загрузите файл

Выберите файл, который вы хотите конвертировать с компьютера, Google Диска, Dropbox или перетащите его на страницу. Шаг 2

Выберите «в dbf»

Выберите dbf или любой другой формат, в который вы хотите конвертировать файл (более 200 поддерживаемых форматов) Шаг 3

Скачайте ваш dbf файл

Подождите пока ваш файл сконвертируется и нажмите скачать dbf -файл

Бесплатное онлайн преобразование dbf

Быстро и легко Просто поместите файлы dbf на страницу, и вы можете преобразовать его в более чем 250 различных форматов файлов без регистрации, указывая электронную почту или водяной знак. Не беспокойтесь о безопасности Мы удаляем загруженные файлы dbf мгновенно и преобразованные файлы через 24 часа. Все файлы передаются с использованием продвинутого шифрования SSL. Все в облаке Вам не нужно устанавливать какое-либо программное обеспечение. Все преобразования dbf происходят в облаке, и не используют какие-либо ресурсы вашего компьютера. —>

Database File
Расширение файла .dbf
Категория файла documents
Описание Dbase, программное обеспечение управления базами данных использующее расширение DBF для хранения своих стандартных файлов базы данных. Однако dbase — не единственная программа для работы с базами данных, совместимая с файлами DBF, поскольку другие программы «xBASE» также поддерживают этот формат файла. DBF получил популярность, потому что его структура проста для понимания, а также была ранее принята сообществом баз данных.
Технические детали DBF-файл содержит несколько наборов данных, которые хранятся и организованы в виде массивов. Он используется в Dbase II в качестве формата файла. Кроме того, он был использован в следующих версиях Dbase III, III + и IV. DBF файл является одним из самых ранних файлов баз данных, имеющих заголовок. Заголовок делает программу незнакомой со структурой данных прочитанного DBF файла. Тем не менее, он может быть использован в Microsoft Excel OpenOffice Calc и некоторых других программах.
Программы Microsoft Access 2016 Microsoft Excel 2016 Microsoft Visual FoxPro Corel Quattro Pro X7 Apache OpenOffice HiBase Group DBF Viewer 2000 Astersoft DBF Manager DBF Viewer Plus DBFView Swiftpage Act! Alpha Software Alpha Anywhere Planamesa NeoOffice (Mac) GTK DBF Editor (Mac & Linux) multisoft FlagShip (Linux)
Основная программа dBase
Разработчик dBASE
MIME type application/dbase application/x-dbase application/dbf application/x-dbf zz-application/zz-winassoc-dbf

FAQ

❓ Как я могу конвертировать dbf? Во-первых, выберите dbf файл, который вы хотите конвертировать или перетащить его. Во-вторых, выбирите формат, в который вы хотите преобразовать файл. Затем нажмите кнопку конвертировать и подождите, пока файл не преобразуется ⏳ Как долго я должен ждать, чтобы преобразовать dbf? Преобразование Документы обычно занимает несколько секунд. Вы преобразовать dbf очень быстро. 🛡️ Безопасно ли конверитровать dbf на OnlineConvertFree? Конечно! Мы удалить загруженные и преобразованные файлы, так что никто не имеет доступ к вашей информации. Все типы конвертации на OnlineConvertFree (в том числе dbf) 100% безопасны. 📱 Можно ли конвертировать dbf без установки программного обеспечения? Да! OnlineConvertFree не требует установки. Вы можете конвертировать любые файлы (в том числе dbf) онлайн на вашем компьютере или мобильном телефоне.

dbf конвертер

dbf в pdf dbf в xls dbf в xlsx dbf в xml dbf в txt dbf в ods dbf в ots dbf в sxc dbf в stc dbf в xlt dbf в csv dbf в sdc —>

Конвертировать в dbf

xls в dbf xlsx в dbf ods в dbf ots в dbf sxc в dbf stc в dbf xlt в dbf csv в dbf wk1 в dbf wks в dbf sdc в dbf

DBF (Data Base File) — формат, применяемый к текстовым и числовым файлам Системы Управления Базой Данных (СУБД). DBF-файл включает  в себя заголовок с порядковым номером формата и саму информацию в виде таблиц определённого размера из записей фиксированной длины. Первый байт содержит номер версии формата и битовую маску дополнений. Файлы добавочных полей и индексов нельзя прочитать без соответствующего им DBF-файла, их описание обычно является составной частью описания формата.

Принадлежит программе XBase и Microsoft Access.

Формат используется во многих бизнес и спецприложениях, к примеру, в продуктах компании 1С, проектировочных программах, инженерных приложениях. Запустить файл нетрудно, нужно лишь изучить несколько правил и подобрать соответствующий продукт или онлайн-сервис.

Чем открыть файл dbf

DBF Commander

DBF Commander даёт возможность экспортировать DBF. Возможны замена и поиск, копирование записей, работа с базой данных помеченной «Только чтение». Предусмотрена смена кодировки, можно проводить фильтрацию и сортировку данных. Чтобы посмотреть базу в dbf-редакторе придерживаемся следующего алгоритма:

  • щёлкните на иконку папки, либо используйте Ctrl+O;
  • выделите нужный документ и кликните на «Открыть»;
  • будет выведена таблица.

DBF Viewer Plus

DBF Viewer Plus позволяет открывать, просматривать данные, печатать и просматривать таблицы. А также редактировать, фильтровать, удалять и добавлять записи, проводить расширенный поиск, создавать файлы, экспортировать документы. Для просмотра файлов формата dbf на компьютере:

  • нужно выбрать первую иконку «Open»;
  • выделить требуемый документ и нажать «Открыть»;
  • отобразится итог в виде таблицы.

DBF Viewer 2000

Приложение с простым интерфейсом. DBF Viewer 2000 даёт возможность работать с документами размером больше 2 ГБ. Для запуска базы данных с расширением dbf нужно:

  • в меню нажмите на первую иконку или используйте комбинацию Ctrl+O;
  • отметьте необходимый документ, нажмите «Открыть»;
  • появится таблица.

  Что такое верификация и где она используется

CDBF

Мощный метод просмотра и редактирования баз данных, можно создавать отчёты. В CDBF предусмотрено расширение функционала за счёт добавочных плагинов. Для просмотра следуем инструкции:

  • кликните по первому значку под опцией «File»;
  • выделите желаемый элемент, нажмите «Открыть»;
  • откроется окно с итогами.

Microsoft Excel

В этом случае можно использовать два варианта.

В первом, для открытия дбф используем опцию «Открыть»:

  • в меню слева надо перейти в пункт «Открыть» и нажать «Обзор»;
  • выделить нужный документ, нажать «Открыть»;
  • появится таблица.

Во втором случае можно установить Microsoft Excel программой по умолчанию:

  • произведите двойной щелчок левой клавишей мышки по нужной базе данных;
  • если в настройках системы формат DBF не увязан ни с каким приложением, то появится окошко, сообщающее о неудачной попытке запуска. ОС предложит методы решить проблему:
    • поиск соответствий в сети;
    • выбор программы из перечня имеющихся на ПК.
  • так как Эксель установлен, то потребуется переставить переключатель на второй пункт и щёлкнуть «OK».

Если же расширение уже увязано с иной программой, но нужно открывать его в Excel, то тогда:

  • кликните по названию файла правой кнопкой мышки;
  • откроется меню. Выберите «Открыть с помощью»;
  • появится перечень. Если в нём присутствует название «Microsoft Excel», кликните по нему. Если нет, то переходите в «Выбрать программу…».

Либо это можно сделать иначе:

  1. Кликните по названию элемента правой кнопкой мышки.
  2. В перечне выберите опцию «Свойства».
  3. На вкладке «Общие», рядом с параметром «Приложение» нажмите на «Изменить…».
  4. Если в перечне рекомендуемых приложений в верхней части окна есть название «Microsoft Excel», то щёлкните по нему, иначе — жмите на «Обзор…» в нижней части окна.
  5. В окошке «Открыть с помощью…» перейдите в папку, содержащую файл запуска Эксель. Точный путь зависит от версии. Общий шаблон: C:Program FilesMicrosoft OfficeOffice#. Вместо знака «#» потребуется вписать № версии Эксель.
  6. Отыщите «EXCEL.EXE». Если в ОС не установлено отображение форматов, то наименование будет «EXCEL». Выделите его и нажмите на «Открыть».
  7. Появится окно выбора программы. Теперь название «Microsoft Excel» будет отображено. Если хотите, чтобы Эксель всегда по умолчанию запускал DBF-файлы двойным нажатием левой кнопки мышки, то проверьте, чтобы рядом с опцией «Применять программу для всех файлов данного вида» стояла галка. Далее нажмите «OK».
  8. После чего документ будет открыт в Excel. И теперь его можно запускать двойным щелчком левой клавиши мышки.

  Презентация Google Nexus Event 2015: подводим итоги

 Чем запустить DBF онлайн

Кроме этого DBF-файлы возможно просмотреть используя онлайн сервисы:

  1. DBFshow.on – удобное приложение, которое позволяет просматривать базы данных.
  2. DBFOpener поможет отобразить содержимое баз данных без установки приложений.

Читайте также:

Содержание

Процесс открытия

Открыть файлы формата DBF можно в нескольких программах. Помимо открытия файла в этих программах его там же можно и редактировать.

Программа 1: DBF Commander

Это платная программа, которая позволяет открывать DBF-файлы и проводить с ними примитивные манипуляции при необходимости. У неё есть пробный период, во время которого возможности программы никак не ограничены. Также в программе присутствует русский язык и удобный интерфейс.

Инструкция по открытию файлов в DBF Commander:

  1. Откройте программу и в верхней панели управления нажмите на иконку папки. Ещё можно воспользоваться комбинацией Ctrl+O.
  2. Появится окно «Проводника», где вам нужно выбрать файл для открытия.
  3. Теперь вы можете редактировать таблицу и видеть её содержимое.

Программа 2: DBF Viewer Plus

Это немного более простая программа, которая имеет схожий интерфейс с предыдущем ПО. Однако она распространяется полностью бесплатно и не требует установки. Функционал практически схож с предыдущем ПО.

Пошаговая инструкция к этой программе выглядит следующим образом:

  1. Запустите программу и в верхней панели управления нажмите на иконку открытой папки с подписью «Open». Для быстродействия можно опять же воспользоваться комбинацией клавиш Ctrl+O.
  2. Откройте нужный файл через «Проводник».
  3. Вы можете просматривать и редактировать содержимое файла.

Программа 3: DBF Viewer 2000

Это программа с очень простым интерфейсом, переведённым на русский язык. Она имеет широкий функционал для работы с файлами формата DBF. Здесь вы можете обрабатывать файлы размером более 2 Гб. Однако ПО платное, правда, имеет пробный период, в ходе которого вы можете пользоваться всеми функциями без ограничений.

Инструкция к открытию файлов в этой программе выглядит следующим образом:

  1. В Верхней панели управления кликните по иконке открытой папки. Опять же можно воспользоваться сочетанием клавиш для быстрого вызова «Проводника»Ctrl+O.
  2. Выберите нужный файл в «Проводнике» и откройте его.
  3. Теперь вы можете просматривать и редактировать документ.

Программа 4: CDBF

Данное решения представляет очень широкий функционал для работы с базами данных и их производными файлами. Помимо редактирования файлов баз данных вы можете создавать различные отчёты и вспомогательные документы. Интерфейс может быть переведён на русский язык, а функционал расширен при помощи сторонних плагинов из сети. CDBF – платная программа, но при этом она имеет как демонстрационный период, так и урезанную бесплатную версию, функционала которой будет достаточно для открытия DBF-файлов.

Инструкция:

  1. Нажмите по иконке открытой папки в верхней панели или используйте комбинацию клавиш Ctrl+O.
  2. В «Проводнике» выберите и откройте нужный файл.
  3. Можете просмотреть или отредактировать таблицу.

Программа 5: MS Excel

Excel – это одна из программа пакета Office от Microsoft. В некоторых версиях Windows этот пакет вместе с программой могут быть уже предустановлены, в других же придётся покупать весь пакет Office, либо воспользоваться демонстрационной версией. Эта программа предназначена для создания и редактирования таблиц различной сложности. Поддерживает множество форматов, а также имеет удобный и функциональный интерфейс на русском языке.

Инструкция по открытию файла DBF выглядит следующим образом:

  1. При работе с файлом нажмите на «Файл» в верхней части программы.
  2. В левом меню выберите пункт «Открыть».
  3. Затем нажмите на иконку папки с подписью «Обзор».
  4. Выберите и откройте нужный файл в «Проводнике».
  5. Теперь вы можете редактировать и просматривать DBF-файл в программе Excel.

Используя одну из программ, представленных в инструкции вы можете открыть и отредактировать DBF-файл. Из всего списка можно выделить только DBF Viewer Plus, который распространяется на полностью бесплатной основе.

Чтение и запись DBF в языке 1С 8.3, 8.2 (в примерах)

Всё для программиста >> Справочник языка 1С

Вступайте в мою группу помощник программиста. В ней мы обсуждаем программирование в 1С.

<<< XML ZIP WORD <span> DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.dbf, который используется в примерах ниже.

/// Как прочитать записи файла в формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакПрочитатьЗаписиФайлаВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF           Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Истина // только чтение );       Сообщить("В таблице " + Таблица.КоличествоЗаписей() + " записей.");     Сообщить("Таблица имеет кодировку: " + Таблица.Кодировка);       Таблица.Первая(); // перешли к первой записи Пока Не Таблица.ВКонце() Цикл Если Не Таблица.ЗаписьУдалена() Тогда             Сообщить(                 Строка(Таблица.EMPLOYEEID) + " " +                 Таблица.LASTNAME + " " +                  Таблица.TITLE + " " +                 Таблица.ADDRESS ); КонецЕсли;         Таблица.Следующая(); // переходим к следующей записи КонецЦикла;           Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как найти нужную запись в файле в формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакНайтиНужнуюЗаписьВФайлеВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF        // Файлы dbf могут быть очень большими и содержать сотни // тысяч записей. В этом случае полный перебор всех записей, // чтобы найти одну - не очень хорошая идея.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       // Но для того, чтобы искать по ключу - нужен индексный файл, // включающий нужные нам поля. Если бы этот файл уже был у нас, // то мы бы передали его при открытии файла вышле, но у нас его // нет, а потому - займёмся его созданием.       // создадим индекс только по полю EMPLOYEEID     Таблица.Индексы.Добавить( "INDEX_EMPLOYEEID", // имя индекса "EMPLOYEEID", // выражение индекса Истина // уникальность создаваемого индекса );       КаталогДляЭкспериментов = КаталогДокументов() + "helpme1c.ru";     СоздатьКаталог(КаталогДляЭкспериментов);       ПутьКФайлуИндекса = КаталогДляЭкспериментов + "test.cdx";       Таблица.СоздатьИндексныйФайл(ПутьКФайлуИндекса);       Таблица.ЗакрытьФайл();       // Заново открываем таблицу, уже на чтение и с индексным файлом, // который мы только что создали.           Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе         ПутьКФайлуИндекса, // путь к индексу Истина // только чтение );       // Найдём среди записей ту, у которой поле EMPLOYEEID равно 3.       // В таблице всего один индекс INDEX_EMPLOYEEID.     Таблица.ТекущийИндекс = Таблица.Индексы.Получить( );        Таблица.Ключ.EMPLOYEEID = "3";       ЗаписьНайдена = Таблица.НайтиПоКлючу("=");       Если ЗаписьНайдена Тогда         Сообщить("Запись найдена");         Сообщить(             Строка(Таблица.EMPLOYEEID) + " " +             Таблица.LASTNAME + " " +              Таблица.TITLE + " " +             Таблица.ADDRESS ); Иначе         Сообщить("Запись не найдена"); КонецЕсли;       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как добавить новые записи в уже существующий файл в /// формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакДобавитьНовыеЗаписиВФайлВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF       // Добавим в уже знакомый нам test.dbf 2 новые записи о работниках.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       Таблица.Добавить();     Таблица.EMPLOYEEID = "100";     Таблица.LASTNAME = "Милькин";     Таблица.TITLE = "Программист";     Таблица.ADDRESS = "Владивосток";     Таблица.Записать();       Таблица.Добавить();     Таблица.EMPLOYEEID = "101";     Таблица.LASTNAME = "Милькина";     Таблица.TITLE = "Биолог";     Таблица.ADDRESS = "Владивосток";     Таблица.Записать();       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как удалить определенные записи в файле в формате /// dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакУдалитьОпределенныеЗаписиИзФайлаВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF           // Удалим записи с LASTNAME Милькин и Милькина       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       Таблица.Первая();       Пока Не Таблица.ВКонце() Цикл Если              СокрЛП(Таблица.LASTNAME) = "Милькин" Или             СокрЛП(Таблица.LASTNAME) = "Милькина" Тогда             Таблица.Удалить(); КонецЕсли;         Таблица.Следующая(); КонецЦикла;       // Но Удалить() только ставит пометку на // удаление, а чтобы реально удалить помеченные // на удаление записи нужно вызвать метод Сжать().       Таблица.Сжать();       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как создать файл в формате dbf с нужными /// полями из 1с 8.3, 8.2   &НаКлиенте Процедура КакСоздатьФайлВФорматеDBFНаКлиенте()       // О формате dbf - https://ru.wikipedia.org/wiki/DBF       НоваяТаблица = Новый XBase;     НоваяТаблица.Кодировка = КодировкаXBase.ANSI;       // Описываем колонки таблицы.       НоваяТаблица.Поля.Добавить( "FIRSTNAME", // имя колонки "S", // тип 100, // длина );     НоваяТаблица.Поля.Добавить( "AGE", "N", 10,   // точность ) ;       // Типы ещё бывают: // N - число // S - строка // D - дата // L - булево // F - число       КаталогДляЭкспериментов = КаталогДокументов() + "helpme1c.ru";     СоздатьКаталог(КаталогДляЭкспериментов);       ПутьКНовомуDBF = КаталогДляЭкспериментов + "new.dbf";           НоваяТаблица.СоздатьФайл(         ПутьКНовомуDBF, // путь к базе // путь к индексу );       НоваяТаблица.ЗакрытьФайл();       Сообщить("Новый файл создан в '" + ПутьКНовомуDBF + "'.");       // И уже теперь можем его открыть и добавить данные.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКНовомуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );           Таблица.Добавить();     Таблица.FIRSTNAME = "Вова";     Таблица.AGE = 31;     Таблица.Записать();       Таблица.Добавить();     Таблица.FIRSTNAME = "Алёна";     Таблица.AGE = 24;     Таблица.Записать();           Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.dbf, который используется в примерах ниже.

Чтение и запись DBF в языке 1С 8.3, 8.2 (в примерах)

<<< XML ZIP WORD <span> DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

С уважением, (преподаватель школы 1С программистов и разработчик обновлятора).Всё для программиста >> Справочник языка 1С

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю). Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

imageКак помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
А как считаете Вы?
Напишите в комментариях, что вы думаете – согласны
ли со статьей или есть что добавить?
Добавить комментарий