Ещё один dbf-редактор, или чем sdbf лучше своих предшественников

Чтение и запись DBF в языке 1С 8.3, 8.2 (в примерах)

Всё для программиста >> Справочник языка 1С

Вступайте в мою группу помощник программиста. В ней мы обсуждаем программирование в 1С.

<<< XML ZIP WORD <span> DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.dbf, который используется в примерах ниже.

/// Как прочитать записи файла в формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакПрочитатьЗаписиФайлаВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF           Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Истина // только чтение );       Сообщить("В таблице " + Таблица.КоличествоЗаписей() + " записей.");     Сообщить("Таблица имеет кодировку: " + Таблица.Кодировка);       Таблица.Первая(); // перешли к первой записи Пока Не Таблица.ВКонце() Цикл Если Не Таблица.ЗаписьУдалена() Тогда             Сообщить(                 Строка(Таблица.EMPLOYEEID) + " " +                 Таблица.LASTNAME + " " +                  Таблица.TITLE + " " +                 Таблица.ADDRESS ); КонецЕсли;         Таблица.Следующая(); // переходим к следующей записи КонецЦикла;           Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как найти нужную запись в файле в формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакНайтиНужнуюЗаписьВФайлеВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF        // Файлы dbf могут быть очень большими и содержать сотни // тысяч записей. В этом случае полный перебор всех записей, // чтобы найти одну - не очень хорошая идея.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       // Но для того, чтобы искать по ключу - нужен индексный файл, // включающий нужные нам поля. Если бы этот файл уже был у нас, // то мы бы передали его при открытии файла вышле, но у нас его // нет, а потому - займёмся его созданием.       // создадим индекс только по полю EMPLOYEEID     Таблица.Индексы.Добавить( "INDEX_EMPLOYEEID", // имя индекса "EMPLOYEEID", // выражение индекса Истина // уникальность создаваемого индекса );       КаталогДляЭкспериментов = КаталогДокументов() + "helpme1c.ru";     СоздатьКаталог(КаталогДляЭкспериментов);       ПутьКФайлуИндекса = КаталогДляЭкспериментов + "test.cdx";       Таблица.СоздатьИндексныйФайл(ПутьКФайлуИндекса);       Таблица.ЗакрытьФайл();       // Заново открываем таблицу, уже на чтение и с индексным файлом, // который мы только что создали.           Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе         ПутьКФайлуИндекса, // путь к индексу Истина // только чтение );       // Найдём среди записей ту, у которой поле EMPLOYEEID равно 3.       // В таблице всего один индекс INDEX_EMPLOYEEID.     Таблица.ТекущийИндекс = Таблица.Индексы.Получить( );        Таблица.Ключ.EMPLOYEEID = "3";       ЗаписьНайдена = Таблица.НайтиПоКлючу("=");       Если ЗаписьНайдена Тогда         Сообщить("Запись найдена");         Сообщить(             Строка(Таблица.EMPLOYEEID) + " " +             Таблица.LASTNAME + " " +              Таблица.TITLE + " " +             Таблица.ADDRESS ); Иначе         Сообщить("Запись не найдена"); КонецЕсли;       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как добавить новые записи в уже существующий файл в /// формате dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакДобавитьНовыеЗаписиВФайлВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF       // Добавим в уже знакомый нам test.dbf 2 новые записи о работниках.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       Таблица.Добавить();     Таблица.EMPLOYEEID = "100";     Таблица.LASTNAME = "Милькин";     Таблица.TITLE = "Программист";     Таблица.ADDRESS = "Владивосток";     Таблица.Записать();       Таблица.Добавить();     Таблица.EMPLOYEEID = "101";     Таблица.LASTNAME = "Милькина";     Таблица.TITLE = "Биолог";     Таблица.ADDRESS = "Владивосток";     Таблица.Записать();       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как удалить определенные записи в файле в формате /// dbf из 1с 8.3, 8.2   &НаКлиенте Процедура КакУдалитьОпределенныеЗаписиИзФайлаВФорматеDBFНаКлиенте(ПутьКФайлуDBF)       // О формате dbf - https://ru.wikipedia.org/wiki/DBF           // Удалим записи с LASTNAME Милькин и Милькина       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКФайлуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );       Таблица.Первая();       Пока Не Таблица.ВКонце() Цикл Если              СокрЛП(Таблица.LASTNAME) = "Милькин" Или             СокрЛП(Таблица.LASTNAME) = "Милькина" Тогда             Таблица.Удалить(); КонецЕсли;         Таблица.Следующая(); КонецЦикла;       // Но Удалить() только ставит пометку на // удаление, а чтобы реально удалить помеченные // на удаление записи нужно вызвать метод Сжать().       Таблица.Сжать();       Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Как создать файл в формате dbf с нужными /// полями из 1с 8.3, 8.2   &НаКлиенте Процедура КакСоздатьФайлВФорматеDBFНаКлиенте()       // О формате dbf - https://ru.wikipedia.org/wiki/DBF       НоваяТаблица = Новый XBase;     НоваяТаблица.Кодировка = КодировкаXBase.ANSI;       // Описываем колонки таблицы.       НоваяТаблица.Поля.Добавить( "FIRSTNAME", // имя колонки "S", // тип 100, // длина );     НоваяТаблица.Поля.Добавить( "AGE", "N", 10,   // точность ) ;       // Типы ещё бывают: // N - число // S - строка // D - дата // L - булево // F - число       КаталогДляЭкспериментов = КаталогДокументов() + "helpme1c.ru";     СоздатьКаталог(КаталогДляЭкспериментов);       ПутьКНовомуDBF = КаталогДляЭкспериментов + "new.dbf";           НоваяТаблица.СоздатьФайл(         ПутьКНовомуDBF, // путь к базе // путь к индексу );       НоваяТаблица.ЗакрытьФайл();       Сообщить("Новый файл создан в '" + ПутьКНовомуDBF + "'.");       // И уже теперь можем его открыть и добавить данные.       Таблица = Новый XBase;     Таблица.ОткрытьФайл(         ПутьКНовомуDBF, // путь к базе , // путь к индексу Ложь // открываем на запись );           Таблица.Добавить();     Таблица.FIRSTNAME = "Вова";     Таблица.AGE = 31;     Таблица.Записать();       Таблица.Добавить();     Таблица.FIRSTNAME = "Алёна";     Таблица.AGE = 24;     Таблица.Записать();           Таблица.ЗакрытьФайл();   КонецПроцедуры   /// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.dbf, который используется в примерах ниже.

Чтение и запись DBF в языке 1С 8.3, 8.2 (в примерах)

<<< XML ZIP WORD <span> DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

С уважением, (преподаватель школы 1С программистов и разработчик обновлятора).Всё для программиста >> Справочник языка 1С

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю). Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

imageКак помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

DBF является стандартным форматом хранения данных. Он позволяет передавать и сохранять нужные сведения электронным таблицам, СУБД. Обязательными составляющими данного файла являются заголовок и область данных. Любому пользователю рано или поздно приходится сталкиваться с этим форматом. В результате возникает вопрос о том, чем открывать DBF. Какой софт поможет решить эту проблему?

Чем открывать DBF в Windows

Не нужно паниковать, если не удается сходу подобрать программу для открытия файла базы данных. Решение проблемы, как правило, находится рядом. Если на компьютере установлен пакет MS Office, можно использовать Excel либо Access. Сначала необходимо запустить приложение, после чего выбрать пункт меню «Открыть» либо нажать клавишную комбинацию CTRL+O. В поле «Тип файлов» указать «Все». Далее можно выбрать нужный документ и открыть его. Если это решение по какой-то причине не подходит, и пользователь все еще не знает, чем открывать DBF, можно рассмотреть альтернативные варианты.

Программы, позволяющие работать с DBF

  • DBFShow (бесплатное приложение, позволяет открывать и редактировать файлы);
  • DBF Viewer Plus (свободное использование, множество функций);
  • MS SQL Server (дорогостоящая СУБД);
  • DBF Commander (распространяется свободно, просмотр и редактирование);
  • MS Access (платная программа из пакета MS Office);
  • CDBF (платная программа, расширенные возможности);
  • MS Excel (входит в набор офисных приложений Microsoft).

Вышеприведенный перечень приложений для открытия файлов баз данных далеко не полон. Однако в нем пользователем наверняка будет найдена нужная программа. Открыть файл DBF с ее помощью он сможет за несколько секунд. Бесплатные приложения легко можно найти и загрузить в Интернете. Использование платного софта предполагает, что пользователь сначала заплатит за использование ПО.

Если возникают проблемы

Что можно сделать, если база данных наотрез отказывается открываться в Excel, а Access не установлен? Чем открывать DBF в таком случае? Не стоит спешить искать другой софт. Если на компьютере установлен пакет MS Office в минимальной конфигурации, то в Excel может отсутствовать специальная надстройка для работы с нашим форматом. Поэтому нужно предварительно найти в сети и загрузить требуемую библиотеку на компьютер.

Файлы библиотеки помещены в архив, и там же находится подробная инструкция по установке. Пользователю, который все еще озадачен вопросом, чем открывать DBF, необходимо выполнить несколько простых действий, скопировав файлы в указанные в инструкции папки. После этого следует зайти в раздел «Надстройки» в программе Excel и поставить галочку рядом с пунктом «Надстройка для работы с ДБФ».

Похожие статьи

Работа с DBF в 1С 8.3 и 8.2 может быть полезна во многих случаях. Типичные примеры — обмен данными с другими учетными системами, загрузка классификаторов КЛАДР и так далее. DBF — формат хранения файлов баз данных, очень распространенный в России и мире.

Система 1С без проблем умеет работать с такими файлами с помощью встроенного объекта системы XBase. Рассмотрим пример чтения и записи в файл dbf.

image

Чтение в 1С из файла DBF

Рассмотрим учебный пример, в котором необходимо заполнить нужный массив из колонки файла dbf. Сам файл расположен по адресу «C:KLADR.DBF».

ПутьКФайлу = "C:KLADR.DBF";    ФайлDBF = Новый XBase; // создаем новый объект  ФайлDBF.ОткрытьФайл(ПутьКФайлу,,Истина); // открытие файла  ФайлDBF.Первая(); // устанавливает курсор на первую запись    МассивАдресов = Новый Массив; // цикл обрабатывается до тех пор, пока не дошел до последней записи Пока НЕ ФайлDBF.ВКонце() Цикл  МассивАдресов.Добавить(ФайлDBF.ADRES);  ФайлDBF.Следующая(); //передвигаем курсор далее КонецЦикла; //обязательно закрываем файл, после прекращения работыФайл    DBF.ЗакрытьФайл(); 

Создание файла

Для создания нового файла DBF в 1C 8.2 или 8.3 следует воспользоватся следующим синтаксисом:

НовыйФайл = Новый XBase; //существует два вида кодировки ANSI (win) и OEM (dos)  НовыйФайл.Кодировка = КодировкаXBase.ANSI; //описываем колонки:  НовыйФайл.Поля.Добавить("ADRES","S",100);  НовыйФайл.Поля.Добавить("DOM","N",10) ;    Путь = "C:KLADR.DBF";  НовыйФайл.СоздатьФайл(Путь);  НовыйФайл.Записать(); 

Запись в DBF

Запись происходит так же несложно, как и другие операции. Запишем некоторые значения из массива в ранее созданный файл:

Для Каждого Адрес из МассивАдресов Цикл  НовыйФайл.Добавить();  НовыйФайл.ADRES = Адрес;  НовыйФайл.Записать(); КонецЦикла;  НовыйФайл.ЗакрытьФайл(); 

Вот и всё, как видите, в работе с  такими файлами баз данных из 1С никаких трудностей не имеется.

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания — попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя. Попробуйте бесплатно по ссылке >>

Другие статьи по 1С программированию.

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Оцените статью, пожалуйста!

разработчикDbae популярность 3,7 (138 голосов) категорияФайлы базы данных ФорматБинарный Х Этот файл сохраняется в двоичном формате, который требует определенной программы для чтения его содержимого.

Содержание:

Тип файла 1 Файл базы данных

разработчик Dbase
популярность 3,7 (138 голосов)
категория Файлы базы данных
Формат Бинарный Х

двоичный

Этот файл сохраняется в двоичном формате, который требует определенной программы для чтения его содержимого.

Что такое файл DBF?

Файл DBF — это стандартный файл базы данных, используемый dBASE, приложением системы управления базами данных. Он организует данные в несколько записей с полями, хранящимися в типе данных массива. Файлы DBF также совместимы с другими программами базы данных «xBase», которые возникли из-за популярности формата файлов. Дополнительная информация

Из-за раннего принятия в сообществе баз данных и относительно простой файловой структуры, файлы DBF были широко приняты в качестве стандартного формата хранения структурированных данных в коммерческих приложениях.

СКАЧАТЬ БЕСПЛАТНО Откройте более 300 форматов файлов с помощью File Viewer Plus. Программы, открывающие файлы DBF

Windows
Dbase
Microsoft Access 2016
Microsoft Excel 2016
Microsoft Visual FoxPro
Corel Quattro Pro X9
Apache OpenOffice
HiBase Group DBF Viewer 2000
Astersoft DBF Manager
DBF Viewer Plus
DBFView
Акт Swiftpage!
Alpha Software Alpha Anywhere
макинтош
Planamesa NeoOffice
Apache OpenOffice
GTK DBF Editor
Linux
Apache OpenOffice
GTK DBF Editor
мультисофт FlagShip

Обновлено 18.08.2016

Тип файла 2FoxPro Table

разработчик N / A
популярность 3,5 (24 голоса)
категория Дата файлы
Формат N / A X

неизвестный

Категории форматов файлов включают в себя двоичные, текстовые, XML и Zip. Формат этого типа файла не был определен.

Ассоциация файлов .DBF 2

Таблица, используемая базой данных, созданной с помощью программ Visual FoxPro, открывающих файлы DBF

Windows
Microsoft Visual FoxPro

Обновлено 2006

О файлах DBF

Наша цель — помочь вам понять, что такое файл с суффиксом * .dbf и как его открыть.

Все типы файлов, описания форматов файлов и программы, перечисленные на этой странице, были индивидуально исследованы и проверены командой FileInfo. Мы стремимся к 100% точности и публикуем информацию только о тех форматах файлов, которые мы тестировали и проверяли.

Если вы хотите предложить какие-либо дополнения или обновления на этой странице, пожалуйста, сообщите нам об этом.

imageИногда пользователям компьютера попадаются файлы с расширением .dbf. Стандартными средствами Windows сразу открыть их не получается. Возникает вопрос о том, как работать с файлами DBF. Открыть их несложно, нужно только знать несколько правил и подобрать программное обеспечение.

Оглавление:

Общие сведения о формате

DBF — формат, применяемый для работы с базами данных. Впервые появился в 1980-м в программе dBase II в качестве основного. С тех пор совершенствовался, расширялся. Благодаря удобству и многолетней привычке и сейчас «стоит на вооружении» во многих коммерческих программах. Формат является одним из стандартных в своей области применения.

Сейчас используется в системах управления данными, программах для работы с электронными таблицами. Структура файла DBF выглядит примерно следующим образом:

  • заголовок — содержит описание файла;
  • основная информация в виде таблицы.

Иногда вместе с ним идут файлы с другими расширениями: .dbt, .fpt. Они не являются самостоятельными и не открываются без основного.

Открыть базу данных DBF можно с помощью стандартных приложений в составе популярных пакетов:

  • Microsoft Office: Microsoft Excel, Microsoft Access;
  • OpenOffice.org.

Существуют и отдельные программы для открытия DBF, например:

  • DBF Viewer Plus;
  • DBF Commander;
  • DBFShow.

Их функционал может заметно отличаться, но при правильном подборе открываются широкие возможности:

  • просмотр, изменение таблиц;
  • сохранение файлов в других распространенных форматах;
  • быстрый и эффективный поиск информации;
  • сортировка, выборка данных;
  • поиск дубликатов и др.

Мы уверены, что Вам будет интересна статья о программах для открытия файлов CDR.

Использование Excel

Чтобы открыть файлы DBF без установки допольнительного софта, можно просто воспользоваться средствами Microsoft Office. Как правило, этот пакет можно встретить на большинстве компьютеров, особенно офисных. Формат не «узнается» стандартными средствами операционной системы, но выход есть. Например, в Microsoft Excel последовательность действий будет такой:

  1. imageЗапустить приложение и вызвать диалоговое окно открытия файлов. Для этого можно использовать стандартное меню открытия или специальную команду, набранную на клавиатуре: нажать «Ctrl» и, удерживая ее, дополнительно — «O».
  2. В нижней части окна нужно выбрать тип файлов: «Все файлы». В выпадающем списке нет DBF, но таким способом обходится ограничение и задействуются все доступные возможности Excel. Как альтернативный вариант — применение технологии «drag-and-drop». В этом случае файл DBF необходимо захватить курсором и перекинуть в рабочую область Excel. Результат — тот же.

Открытие по умолчанию

Описанный выше способ эффективен, но не всегда удобен. Недостатком является то, что открывать каждый раз приходится вручную. Автоматизировать процесс можно, выполнив несколько простых действий:

  1. imageИспользоваться будет привычное меню «Проводника». Правой кнопкой нужно кликнуть по документу с расширением .dbf.
  2. Из выпавшего меню выбирается нужный пункт: «Открыть с помощью…».
  3. В появившемся окошке требуется найти нужное приложение, например, Excel. Оно может быть в «Рекомендуемых программах». Если там нет, следует поискать чуть ниже в «Других программах». Если здесь пусто, необходимо нажать напротив «крестик», и они появятся. На будущее, для подобных случаев есть еще кнопка «Обзор» чуть ниже. Там также можно выбрать интересующую программу в ручном режиме.
  4. Для того чтобы выделенное приложение применялось каждый раз автоматически, нужно поискать внизу соответствующую надпись: «Использовать выбранную программу для всех файлов такого типа». Напротив нее ставится «галочка».
  5. Процедура заканчивается нажатием кнопки «OK» или двойным щелчком по названию нужной программы. Теперь файлы будут открываться сразу, так как по умолчанию уже выставлены все необходимые настройки.

Того же результата можно добиться другим простым путем, также с участием «Проводника»:

  1. Файл DBF выделяется правой кнопкой мышки. В открывшемся меню интересуют «Свойства».
  2. В появившемся окошке есть кнопка «Изменить». Ее нужно нажать и выбрать нужное приложение, например, Excel.
  3. Нажать кнопку «OK» сначала в окне выбора, а затем — в окне «Свойства».

Аналогичным образом можно использовать вместо Excel приложение Access. Это лишь вопрос личных предпочтений.

С помощью онлайн-ресурсов

Если нужны другие способы работы с DBF, на просторах Сети можно легко скачать онлайн одну из специализированных программ. Выбор серьезного софта особенно велик, но за него, скорее всего, придется платить. Несмотря на широкую борьбу с пиратством, в интернете много «крякнутых» коммерческих программ. Они часто распространяются свободно, однако стоит соблюдать осторожность. В таких подарках могут быть вирусы.

Есть изначально бесплатные программы для чтения DBF неплохого качества. Хорошим примером может служить DBFShow. Занимает немного места и при этом довольно много может. Помимо просмотра, здесь осуществляется:

  • imageкопирование, вставка фрагментов таблицы;
  • усечение файла;
  • сортировка;
  • фильтрация;
  • удаление и восстановление записей и пр.

Есть и еще один довольно экзотический для новичков способ открытия формата. Для этого файл нужно скопировать на специальный сервер, где он и откроется. Результат доступен для ознакомления.

Если установлен не Microsoft Office, есть смысл попробовать открыть DBF в своем пакете с помощью встроенного табличного редактора. В известных продуктах такая возможность обычно реализована.

Это интересно

  • Как узнать и восстановить свою учетную запись майкрософт
  • Как сделать брошюру в ворде: пошаговая инструкция
  • Способы постановки тире в Ворде
  • Добавление музыки в презентацию Powerpoint на все слайды
  • Как быстро восстановить несохраненный документ Word 2003, 2007, 2010

image

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
А как считаете Вы?
Напишите в комментариях, что вы думаете – согласны
ли со статьей или есть что добавить?
Добавить комментарий